MAVENT Fail after CD for under-disclosing Interest Payments over the life a loan CONV\PMI\Second Home or Investment
If you receive a similar error (See Below) that you can not attribute to any fees not being included in the APR and your loan is CONV, Second Home or Investment, with PMI, you need to manually enter the months of required PMI.
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The disclosed finance charge ($216,843.52) is ($920.74) below the actual finance charge($217,764.26). The Truth in Lending Act considers the disclosed finance charge inaccurate if it is more than $100 below the actual finance charge. (12 CFR 1026.18(d)(1); OSC 17(c)(2)(ii)-1)
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Cause:
Mavent is coded to drop off MI at 78% for First Lien, Primary Residence, Single Family (Units =1) conventional loans. For loans where the property type is listed as Conventional SECOND/VACATION HOME, Conventional INVESTMENT PROPERTY, or Conventional MULTI UNIT PROPERTY (UNITS = 2-4), Mavent is coded to charge MI for the life of the loan.
The Homeowner's Protection Act of 1998 (HOEPA) provides for automatic termination of mortgage insurance on a loan when the outstanding principal balance is equal to or less than 78% of the lesser of the sales price or the appraised value of the property securing the loan. If monthly private mortgage insurance is submitted to the Encompass Compliance Service (ECS), ECS will automatically drop-off the monthly PMI when it reaches this federal threshold. However, ECS will apply the HOEPA rules only to a single family primary dwelling of the borrower.
FIX:
To allow Mavent to read MI drop off correctly for Conventional SECOND/VACATION HOME, Conventional INVESTMENT PROPERTY, or Conventional MULTI UNIT PROPERTY (UNITS = 2-4), please follow the steps listed below:
1) Go to Forms - Select the RegZ LE or RegZ CD
2) Scroll down to Mortgage Insurance Area
3) Click on View Payment Schedule and note the month at which MI payments cease.
4) Go to the EDIT MI function in the MORTGAGE INSURANCE setup
5) Edit MI Line 1 to reflect the final month that MI is charged to correspond with the Payment Schedule (from above)
6) Remove info on line 2
7) Re-Run Compliance Report
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